HowTo: Configue a Cisco Router for simple ADSL home networking

So you’ve taken the plunge and gone and bought yourself a Cisco router and now you want to hook it up to the phone line and use it instead of whatever router you currently use. When complete, your router will be able to assign IP addresses via DHCP and route to and from the internet. This tutorial does not cover security or advanced features.

This tutorial will go through the basics of setting up an ADSL connection to a non-switching router. It assumes you are capable of basic configuration tasks. The configuration above was tested on a Cisco 2821 1024/256 running IOS 15.1 with 2 Gigabit ethernet ports, and a WIC-1ADSL card.

  1. Connect up the router so you can access the terminal via the serial line. Connect an ethernet cable from the port to your switch or computer and the ADSL cable to the phone line via a micro filter.
  2. Clear the startup config and reload the router. Remember to back up any configuration you currently run unless you want to lose it!
  3. Enter the configuration mode (conf terminal)
  4. Enter the following commands:
    • ip dhcp excluded 192.168.1.1 This stops the router assigning this address via DHCP
    • ip dhcp pool main_pool This creates a pool of IP addresses called main_pool
    • network 192.168.1.0 255.255.255.0 This sets the IP range and subnet of the pool
    • default-router 192.168.1.1 This is the default gateway
    • dns-server 8.8.8.8 This is the DNS server connected devices are given. Multiple servers can be specified by seperating addresses with a space. 8.8.8.8 is a Google DNS server. For best performance put the servers provided by your ISP first
    • exit
    • int gi0/0 Select the first Gigabit Ethernet interface. Substitute for your ethernet interface
    • no shutdown Enable the port
    • ip address 192.168.1.1 255.255.255.0 Set the IP address and subnet of the interface
    • ip nat inside Set the interface as being the LAN side of the network
    • no ip directed-broadcast Disable directed broadcasts
    • exit
    • int atm0/1/0 Select the ADSL interface. Substitute for your ADSL interface
    • no shutdown Enable the port
    • no ip address Do not give this interface an IP address
    • no ip directed-broadcast Disable directed broadcasts
    • no mroute-cache Do not use mroute cache
    • pvc 0/38 Get this value from your ISP. Most ADSL connections in the UK use 0/38
    • encapsulation aal5mux ppp dialer Sets the encapsulation type and connection method
    • dialer pool-member 1 Use dialler1 to make the connection
    • exit
    • int dialer1 Select the dialer1 interface
    • ip address negotiated Get the IP address from the ISP dynamically
    • no ip directed-broadcast Disable directed broadcasts
    • ip nat outside Set the interface as being the WAN side of the network
    • encapsulation ppp Use PPP encapsulation
    • dialer pool 1 Use dialer pool 1
    • ppp chap hostname joe.bloggs@myisp.com The username your ISP gave you
    • ppp chap password abcd1234 The password your ISP gave you
    • ppp pap sent-username joe.bloggs@myisp.com password abcd1234 The username and password your ISP gave you
    • exit
    • ip nat inside source list 1 interface dialer1 overload Enable overloaded natting from dialler1 to all the inside addresses according to access list 1
    • ip classless Use classless routing
    • ip route 0.0.0.0 0.0.0.0 dialer1 Set the default route as the dialer – to the internet
    • access-list 1 permit 192.168.1.0 0.0.0.255 Allow all traffic from the internet
    • exit

     

  5. Save your configuration and reload the PC and/or switches to obtain IP addresses. You should now be able to go on the internet. If not, try restarting the router.
Share

1 Comment

  1. cisco router vpn configuration step by step tv show

    An impressive share! I have just forwarded this onto a coworker who had been doing a
    little homework on this. And he actually bought me dinner because I discovered it for him…
    lol. So let me reword this…. Thanks for the meal!! But yeah, thanx for spending some time to discuss this
    matter here on your web site.

    Reply

Leave a Comment

Your e-mail address will not be published. Required fields are marked *